$re = '/for\ tomorrow[^.]*/m';
$str = 'The weather forecast for today is mostly sunny. The forecast for tomorrow will be rainy.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;