package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\((?<Classification>[U|S])\)(?<Content>[^\(*)]*)`)
var str = `(U) foo bar
some more text
(S) yep here too`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}