using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(*NO_AUTO_POSSESS)(*NO_START_OPT)^<option[\s]value[\s]*=[\s]*\""([^\"">]*)\""[\s]*[^>]*>";
string input = @"<option value .";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}