const regex = /proc_notes_(January|February|March|April|May|June|July|August|September|October|November|December)\d{4}.txt/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('proc_notes_(January|February|March|April|May|June|July|August|September|October|November|December)\\d{4}.txt', 'gm')
const str = `proc_notes_April2020.txt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}