$re = '/(?ix)(?:^[A-Z\W]*\W+(?!bnd|cnr)\W+)?(?:(?!\b(?:RD|HWY|TRAIL|St|R)\b)(?P<numbers>\d+-\d+|\d+[A-Z]?)\W+)*?(?:\W+(?:AND|&)\W+)*(?:(?:(?P<geo>BND|CNR)(?:\WOF|\WBY)?)\W+)*(?P<name>(?:(?!\b(?:RD|HWY|TRAIL|St|R)\b)[A-Z]+\W*)+)\W+(?:(?P<type>RD|HWY|TRAIL|St|R)\W)+/';
$str = 'convention centre, bnd by swanston st and avoca st
cnr the hyatt and roland st 123 hudson st BND BY THOMAS RAIL TRAIL, 7 SNOW WHITE HWY & MICKEY RD, 337-343 BOGEYMAN RD, 4, 8, 9-13, 16-18 Fictional Rd & 17B Elm St near junction';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);