import re
regex = re.compile(r"(?ix)(?:^[A-Z\W]*\W+(?!bnd|cnr)\W+)?(?:(?!\b(?:RD|HWY|TRAIL|St|R)\b)(?P<numbers>\d+-\d+|\d+[A-Z]?)\W+)*?(?:\W+(?:AND|&)\W+)*(?:(?:(?P<geo>BND|CNR)(?:\WOF|\WBY)?)\W+)*(?P<name>(?:(?!\b(?:RD|HWY|TRAIL|St|R)\b)[A-Z]+\W*)+)\W+(?:(?P<type>RD|HWY|TRAIL|St|R)\W)+")
test_str = ("convention centre, bnd by swanston st and avoca st\n"
"cnr the hyatt and roland st 123 hudson st BND BY THOMAS RAIL TRAIL, 7 SNOW WHITE HWY & MICKEY RD, 337-343 BOGEYMAN RD, 4, 8, 9-13, 16-18 Fictional Rd & 17B Elm St near junction")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")