Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
(?ix)(?:^[A-Z\W]*\W+(?!bnd|cnr)\W+)?(?:(?!\b(?:RD|HWY|TRAIL|St|R)\b)(?P<numbers>\d+-\d+|\d+[A-Z]?)\W+)*?(?:\W+(?:AND|&)\W+)*(?:(?:(?P<geo>BND|CNR)(?:\WOF|\WBY)?)\W+)*(?P<name>(?:(?!\b(?:RD|HWY|TRAIL|St|R)\b)[A-Z]+\W*)+)\W+(?:(?P<type>RD|HWY|TRAIL|St|R)\W)+
"
g
Input 1
1
New
convention centre, bnd by swanston st and avoca st cnr the hyatt and roland st 123 hudson st BND BY THOMAS RAIL TRAIL, 7 SNOW WHITE HWY & MICKEY RD, 337-343 BOGEYMAN RD, 4, 8, 9-13, 16-18 Fictional Rd & 17B Elm St near junction