use strict;
my $str = '<table border="1" cellpadding="7" cellspacing="0">
<tr>
<td colspan="2" bgcolor="#D3EDF6" align="center">1</td>
<td width="98%" valign="top">2</td>
</tr>
<tr>
<td valign="top" align="center">3</td>
<td width="98%" valign="top">-4314 </td>
<td class="resclass"> Вероника Аполлоновна, +ТЕКСТ, текст, текст-текст, тЛТ-5м, п/текст, д/1/текст/текст, текст/текст</td>
</tr>
<tr>
<td colspan="2" bgcolor="#D3EDF6" align="center">6</td>
</tr>
<tr>
<td valign="top" align="center">7</td>
<td width="98%" valign="top">8</td>
<td class="resclass"> Вероника Аполлоновна, +ТЕКСТ, текст, текст-текст, тЛТ-5м, п/текст, д/1/текст/текст, текст/текст</td>
</tr>
</table>';
my $regex = qr/(<\/td>[^<]*<td[^>]*>)\s*\S+\s\S+,\s*([^<]* <\/td> [^<]* <\/tr>)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}