# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<\/td>[^<]*<td[^>]*>)\s*\S+\s\S+,\s*([^<]* <\/td> [^<]* <\/tr>)"
test_str = ("<table border=\"1\" cellpadding=\"7\" cellspacing=\"0\">\n"
" <tr>\n"
" <td colspan=\"2\" bgcolor=\"#D3EDF6\" align=\"center\">1</td>\n"
" <td width=\"98%\" valign=\"top\">2</td>\n"
" </tr>\n"
" <tr>\n"
" <td valign=\"top\" align=\"center\">3</td>\n"
" <td width=\"98%\" valign=\"top\">-4314 </td>\n"
" <td class=\"resclass\"> Вероника Аполлоновна, +ТЕКСТ, текст, текст-текст, тЛТ-5м, п/текст, д/1/текст/текст, текст/текст</td>\n"
" </tr>\n"
" <tr>\n"
" <td colspan=\"2\" bgcolor=\"#D3EDF6\" align=\"center\">6</td>\n"
" </tr>\n"
" <tr>\n"
" <td valign=\"top\" align=\"center\">7</td>\n"
" <td width=\"98%\" valign=\"top\">8</td>\n"
" <td class=\"resclass\"> Вероника Аполлоновна, +ТЕКСТ, текст, текст-текст, тЛТ-5м, п/текст, д/1/текст/текст, текст/текст</td>\n"
" </tr>\n"
"</table>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.