package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9-]{0,8}([-][0-9-]{0,8})?$`)
var str = `20220623-19563352
20220623-18261367
20220606-15484894
20220606-15484
20220606
20220606-15
202206
33333333-33333333333
5453345345345353434646
3463334334535
202206a
2022067-+`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}