Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^[0-9-]{0,8}([-][0-9-]{0,8})?$
/
mg
Input 1
1
New
20220623-19563352 20220623-18261367 20220606-15484894 20220606-15484 20220606 20220606-15 202206 33333333-33333333333 5453345345345353434646 3463334334535 202206a 2022067-+