package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(,|\r?\n|\r|^)(?:"([^"]*(?:""[^"]*)*)"|([^",\r\n]*))`)
var str = `"1","test","booth","","2024/09/11","2024/08/20","1000","2000","","1","プレミアムウォーター","0","",""`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}