#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\|(?>opening|insert|ending)\=)"
Local $sString = "|mechanics={{mecha|p=GAT-04 Windam}}{{mecha|p=ZGMF-X23S Saviour Gundam}}{{mecha|p=Neutron Stampeder}}|opening={{track|p=Ignited}}" & @CRLF & _
"|insert={{track|p=Mizu no Akashi}}" & @CRLF & _
"|ending={{track|p=Reason}}}}"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)