using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\|(?>opening|insert|ending)\=)";
string substitution = @"";
string input = @"|mechanics={{mecha|p=GAT-04 Windam}}{{mecha|p=ZGMF-X23S Saviour Gundam}}{{mecha|p=Neutron Stampeder}}|opening={{track|p=Ignited}}
|insert={{track|p=Mizu no Akashi}}
|ending={{track|p=Reason}}}}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}