import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\|(?>opening|insert|ending)\\=)";
final String string = "|mechanics={{mecha|p=GAT-04 Windam}}{{mecha|p=ZGMF-X23S Saviour Gundam}}{{mecha|p=Neutron Stampeder}}|opening={{track|p=Ignited}}\n"
+ "|insert={{track|p=Mizu no Akashi}}\n"
+ "|ending={{track|p=Reason}}}}";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}