use strict;
my $str = '|mechanics={{mecha|p=GAT-04 Windam}}{{mecha|p=ZGMF-X23S Saviour Gundam}}{{mecha|p=Neutron Stampeder}}|opening={{track|p=Ignited}}
|insert={{track|p=Mizu no Akashi}}
|ending={{track|p=Reason}}}}';
my $regex = qr/(\|(?>opening|insert|ending)\=)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";