const regex = /^(0|-?0\.\d+|-?[1-9]\d{0,14}|-?[1-9]\d{0,18}\.\d+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(0|-?0\\.\\d+|-?[1-9]\\d{0,14}|-?[1-9]\\d{0,18}\\.\\d+)$', 'gm')
const str = `INTEGER 15digits
0
1
-1
12
-12
123456789012345
-123456789012345
INVALID
01
-01
1234567890123456
-1234567890123456
.123456
-.123456
0.
-0.
1234567890123456789012
-1234567890123456789012
12345678901234567890.1
-12345678901234567890.1
FLOAT (...)
0.1234567890123456789
-0.1234567890123456789
1.1234567890123456789
-1.1234567890123456789
12.123456789012345678
-12.123456789012345678
1234567890123456789.1
-1234567890123456789.1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}