package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)useFsFlag[(](?:\s*(".*"),\s*(".*\s*[^"]*"|[^)]*))\s*[)]`)
var str = ` const backgroundColorFlag = useFsFlag("backgroundColor", "green")
const btnColorFlag = useFsFlag("btnColor", red)
const backgroundSize = useFsFlag("backgroundColor", 16).getValue()
const backgroundSize = useFsFlag("backgroundColor", 16.5).getValue()
const showBtn = useFsFlag("showBtn", true).getValue()
const showBtn = useFsFlag("showBtn",true)
const showBtn = useFsFlag("showBtn", "Blue, red")
const showBtn = useFsFlag("showBtn", "(Blue )[@)à.""h""ere)").getValue()
const showBtn = useFsFlag(
"showBtn",
"(Blue )he{}re)"
) //comment
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}