#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((.)(?:(?1)|.?)\2|(.)\3*)$"
Local $sString = "a" & @CRLF & _
"aa" & @CRLF & _
"aba" & @CRLF & _
"abba" & @CRLF & _
"aaaa" & @CRLF & _
"aaaaa" & @CRLF & _
"abccba" & @CRLF & _
"12344321" & @CRLF & _
"0000010000" & @CRLF & _
"1234567890123456" & @CRLF & _
"1234321" & @CRLF & _
"bbbbbbbbbbbbbbb" & @CRLF & _
"aaaaaaaaaaa" & @CRLF & _
"abcdefghihgfedc" & @CRLF & _
"abcba" & @CRLF & _
"123431" & @CRLF & _
"ab" & @CRLF & _
"1232" & @CRLF & _
"上海自来水来自海上" & @CRLF & _
"ABCBAABCBA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")