using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((.)(?:(?1)|.?)\2|(.)\3*)$";
string input = @"a
aa
aba
abba
aaaa
aaaaa
abccba
12344321
0000010000
1234567890123456
1234321
bbbbbbbbbbbbbbb
aaaaaaaaaaa
abcdefghihgfedc
abcba
123431
ab
1232
上海自来水来自海上
ABCBAABCBA";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}