use strict;
my $str = 'a
aa
aba
abba
aaaa
aaaaa
abccba
12344321
0000010000
1234567890123456
1234321
bbbbbbbbbbbbbbb
aaaaaaaaaaa
abcdefghihgfedc
abcba
123431
ab
1232
上海自来水来自海上
ABCBAABCBA';
my $regex = qr/^((.)(?:(?1)|.?)\2|(.)\3*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}