Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^(?'line'public (?'type'\w+\??) (?'property'[A-z]+).*)$
/
gm
Input 1
1
New
public string? PropertyA { get; set; } public string? PropertyB { get; set; } public int? PropertyC { get; set; }
Substitution
/// <summary>\n/// $property\n/// <\/summary>\n$line\n