package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Nov(ember)*\.*\s\d{1,2}(st|nd|rd|th)*\,*\s\d{4}`)
var str = `Agenda November 9, 2018- Schuck-Lawrence.docx
Attendance Sheet Nov. 9, 2018 - Schuck-Lawrence.docx
Notice of IEP - Nov. 18th 2021
st
nd
rd
th
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}