$re = '/^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9]).{7,}$/m';
$str = 'PÜaй1212121211221!
йййййййй11111222!x
Ppeepeee12ssxxxaa
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);