#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Za-z0-9 \t\r_]*[A-Za-z][A-Za-z0-9 \t\r_]*$"
Local $sString = "ameya123" & @CRLF & _
"ameya" & @CRLF & _
"AMeya12" & @CRLF & _
"Ameya_123" & @CRLF & _
"Ameya_ 123" & @CRLF & _
"123" & @CRLF & _
"_" & @CRLF & _
" " & @CRLF & _
"$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")