using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Za-z0-9 \t\r_]*[A-Za-z][A-Za-z0-9 \t\r_]*$";
string input = @"ameya123
ameya
AMeya12
Ameya_123
Ameya_ 123
123
_
$";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}