import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Za-z0-9 \\t\\r_]*[A-Za-z][A-Za-z0-9 \\t\\r_]*$";
final String string = "ameya123\n"
+ "ameya\n"
+ "AMeya12\n"
+ "Ameya_123\n"
+ "Ameya_ 123\n"
+ "123\n"
+ "_\n"
+ " \n"
+ "$";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}