import re
regex = re.compile(r"^[A-Za-z0-9 \t\r_]*[A-Za-z][A-Za-z0-9 \t\r_]*$", flags=re.MULTILINE)
test_str = ("ameya123\n"
"ameya\n"
"AMeya12\n"
"Ameya_123\n"
"Ameya_ 123\n"
"123\n"
"_\n"
" \n"
"$")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")