using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(<img)(?=((?:[^>""']|""[^""]*""|'[^']*')*?\s)(src\s*=\s*(['""])\/mycms\/~\/media\/([a-f0-9]{32})\.ashx\4)((?:""[\S\s]*?""|'[\S\s]*?'|[^>]*?)+>))\s+(?:""[\S\s]*?""|'[\S\s]*?'|[^>]*?)+>";
string substitution = @"$1$2src='NEWID:key{$5}'$6";
string input = @"<a hello world href=""/mycms/~/link.aspx?_id=D9423CEFED254610A5DC6B096A297E17&_z=z"" class>
...
</a>
<img hello world src=""/mycms/~/media/B1FB91AC357347BD84913D56B8791D03.ashx"" alt="" width=""690"" height=""202"" />
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}