const regex = /(?i)(<img)(?=((?:[^>"']|"[^"]*"|'[^']*')*?\s)(src\s*=\s*(['"])\/mycms\/~\/media\/([a-f0-9]{32})\.ashx\4)((?:"[\S\s]*?"|'[\S\s]*?'|[^>]*?)+>))\s+(?:"[\S\s]*?"|'[\S\s]*?'|[^>]*?)+>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)(<img)(?=((?:[^>"\']|"[^"]*"|\'[^\']*\')*?\\s)(src\\s*=\\s*([\'"])\\\/mycms\\\/~\\\/media\\\/([a-f0-9]{32})\\.ashx\\4)((?:"[\\S\\s]*?"|\'[\\S\\s]*?\'|[^>]*?)+>))\\s+(?:"[\\S\\s]*?"|\'[\\S\\s]*?\'|[^>]*?)+>', '')
const str = `<a hello world href="/mycms/~/link.aspx?_id=D9423CEFED254610A5DC6B096A297E17&_z=z" class>
...
</a>
<img hello world src="/mycms/~/media/B1FB91AC357347BD84913D56B8791D03.ashx" alt="" width="690" height="202" />
`;
const subst = `$1$2src='NEWID:key{$5}'$6`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);