#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[A-Za-z\d].*\R)+?(?:[A-Za-z].*\R){2}(?:Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)\d{4}$"
Local $sString = "ABC" & @CRLF & _
"44234234" & @CRLF & _
"GHG" & @CRLF & _
"FGyhyh" & @CRLF & _
"Nov2016" & @CRLF & _
"/////////////////////////" & @CRLF & _
"ABCtt" & @CRLF & _
"44234234" & @CRLF & _
"GHG" & @CRLF & _
"00" & @CRLF & _
"FGyhyh" & @CRLF & _
"Nov2015" & @CRLF & _
"/////////////////////////" & @CRLF & _
"ABC" & @CRLF & _
"44234234" & @CRLF & _
"GHG" & @CRLF & _
"hyh" & @CRLF & _
"Jan2022" & @CRLF & _
"/////////////////////////"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")