const regex = / a(?= )/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' a(?= )', 'g')
const str = `x a y a x
x a a a x
x aa x`;
const subst = ` b`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);