package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[0-9]+.[0-9]+`)
var str = `1.23
98.76
114-514
0u0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}