$re = '/[0-9]+.[0-9]+/';
$str = '1.23
98.76
114-514
0u0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);