#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "0*\+?(?:972)?(\d+)"
Local $sString = "0527691234" & @CRLF & _
"00527691234" & @CRLF & _
"527691234" & @CRLF & _
"00972527691234" & @CRLF & _
"972527691234" & @CRLF & _
"+972527691234" & @CRLF & _
""
Local $sSubst = "0$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)