re = /0*(?:\+?972)?(?<tel>\d+)/
str = '0527691234
00527691234
527691234
00972527691234
972527691234
+972527691234
'
subst = '0${tel}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result