use strict;
my $str = '&hello=HI1&op=1h23&hello=&op=&hello=HI3&op=&hello=HI4&op=OP4';
my $regex = qr/hello=[a-z\s0-9]+&op=[a-z0-9]*/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}