package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{1,3},)*(\d{1,3})(\.\d{1,3})?$`)
var str = `1,478.25
1,450
48.10
145.124.14`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}