re = /^(\d{1,3},)*(\d{1,3})(\.\d{1,3})?$/m
str = '1,478.25
1,450
48.10
145.124.14'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end