import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?ms)^([^\\|]+\\|){5}(?<field1>\\w+).*\\\"GET\\s+(http|https):\\\\\\\\(?<field2>[^\\/]+)[^\\\"]+\\\"\\s+(?<field3>\\d+)";
final String string = "<random ip address>|-NA\\CAPITA|5xxhxh545|jljdjhsdhj78987|hkjhkdjfkjfd5672v2hg7|87675678vf6x_\n"
+ "<random date time> \"GET http:\\\\at-abc.com http/1.1\" 500 <random values>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}