$re = '/color\(RGB\((\d+)\,(\d+)\,(\d+)\)\)/m';
$str = 'color(RGB(11,22,33))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);