using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[Cc](?<![Yy]ellow [Cc])(?<![Bb]lue [Cc])(?<![Rr]ed [Cc])(?<![Pp]urple [Cc])(?<![Bb]lack [Cc])olor";
string input = @"Dark Color #match
light color #match
Blue Color
red color
that is a blue color and theme
opaque color #match
purple color";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}