package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*(.{0,23}\S)(?:\s+(.{0,29}\S))?\s*$`)
var str = ` 1 Apple Park Way. Cupertino, CA 95014
1600 Amphitheatre Parkway Mountain View, CA 94043
123456789012345678901234567890123456789012345678901234
123456789012345678901234
12345678901234 123456789012345678901234567890`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}