const regex = /^\s*(.{0,23}\S)(?:\s+(.{0,29}\S))?\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(.{0,23}\\S)(?:\\s+(.{0,29}\\S))?\\s*$', 'gm')
const str = ` 1 Apple Park Way. Cupertino, CA 95014
1600 Amphitheatre Parkway Mountain View, CA 94043
123456789012345678901234567890123456789012345678901234
123456789012345678901234
12345678901234 123456789012345678901234567890`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}