# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*(.{0,23}\S)(?:\s+(.{0,29}\S))?\s*$"
test_str = (" 1 Apple Park Way. Cupertino, CA 95014 \n\n"
"1600 Amphitheatre Parkway Mountain View, CA 94043\n\n"
"123456789012345678901234567890123456789012345678901234\n\n"
"123456789012345678901234\n\n"
"12345678901234 123456789012345678901234567890")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.