import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?sm)^(\\d{2}:\\d{2}:\\d{2}\\.\\d+) +--> +(\\d{2}:\\d{2}:\\d{2}\\.\\d+)((?:(?!\\r?\\n\\r?\\n).)*)";
final String string = "00:00:02.736 --> 00:00:06.072 line:79.33% position:10.00% align:start \n"
+ " AND YOUR GRACE?\n\n"
+ "00:00:06.072 --> 00:00:08.875 line:74.00% position:10.00% align:start \n"
+ " WHAT WILL YOU DO\n"
+ " ABOUT THAT?";
final String subst = "|";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}