# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?sm)^(\d{2}:\d{2}:\d{2}\.\d+) +--> +(\d{2}:\d{2}:\d{2}\.\d+)((?:(?!\r?\n\r?\n).)*)"
test_str = ("00:00:02.736 --> 00:00:06.072 line:79.33% position:10.00% align:start \n"
" AND YOUR GRACE?\n\n"
"00:00:06.072 --> 00:00:08.875 line:74.00% position:10.00% align:start \n"
" WHAT WILL YOU DO\n"
" ABOUT THAT?")
subst = "|"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.