import Foundation
let pattern = #"(?sm)^(\d{2}:\d{2}:\d{2}\.\d+) +--> +(\d{2}:\d{2}:\d{2}\.\d+)((?:(?!\r?\n\r?\n).)*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
00:00:02.736 --> 00:00:06.072 line:79.33% position:10.00% align:start
AND YOUR GRACE?
00:00:06.072 --> 00:00:08.875 line:74.00% position:10.00% align:start
WHAT WILL YOU DO
ABOUT THAT?
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"|"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)