using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<Name>Description<\/Name><Value>).*?(?=<\/Value>)";
string input = @"<Rows><Row><Attributes><Column><Name>ID</Name><Value>1111</Value></Column><Column><Name>Number</Name><Value>2222</Value></Column><Column><Name>Type</Name><Value>Solution Changed</Value></Column><Column><Name>Date</Name><Value>12/11/2020 8:01:22 AM</Value></Column><Column><Name>Operator</Name><Value>problem</Value></Column><Column><Name>Description</Name><Value>Solution changed from </Value></Column><Column><Name>VisibleToCustomer</Name><Value>N</Value></Column></Attributes></Row><Row><Attributes><Column><Name>ID</Name><Value>33333</Value></Column><Column><Name>Number</Name><Value>555</Value></Column><Column><Name>Type</Name><Value>Resolved Time Changed</Value></Column><Column><Name>Date</Name><Value>12/11/2020 8:01:22 AM</Value></Column><Column><Name>Operator</Name><Value>problem</Value></Column><Column><Name>Description</Name><Value>Resolved Time changed</Value></Column><Column><Name>VisibleToCustomer</Name><Value>N</Value></Column></Attributes></Row><Row><Attributes><Column><Name>ID</Name><Value>888888</Value></Column><Column><Name>Number</Name><Value>6677</Value></Column><Column><Name>Type</Name><Value>Updated By Changed</Value></Column><Column><Name>Date</Name><Value>12/11/2020 8:01:22 AM</Value></Column><Column><Name>Operator</Name><Value>problem</Value></Column><Column><Name>Description</Name><Value>Updated By changed from</Value></Column><Column><Name>VisibleToCustomer</Name><Value>N</Value></Column></Attributes></Row></Rows>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}