#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(SAIL_Recipes\.md)(\#)(.*?)(?=\))"
Local $sString = "" & @CRLF & _
"Now instead of numbers in the status column, there are words like *Assigned* and *Completed*. For an example that uses an image column to display an icon for process statuses, see the [Display Processes by Process Model with Status Icons](SAIL_Recipes.md#Display_Processes_by_Process_Model_with_Status_Icons) SAIL recipe." & @CRLF & _
"" & @CRLF & _
"## <a id="Add_a_Predefined_Filter"></a> Add a Predefined Filter ##" & @CRLF & _
"" & @CRLF & _
"(#Display_Processes_by_Process_Model_with_Status_Icons) SAIL recipe."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")